Adobe AEM with JavaAgent enabled keeps disconnecting from the Enterprise Manager
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Adobe AEM with JavaAgent enabled keeps disconnecting from the Enterprise Manager

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Article ID: 142904

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Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

The adobe AEM instrumented with JavaAgent keeps disconnecting from the Introscope EM, the APM Agent log reports continuous connection and disconnection every 30s:

[DEBUG] [IntroscopeAgent.IncomingMessageDeliveryTask] Unrecoverable exception while reading from Socket Transport connected with Socket[addr=/<ip_address>,port=5001,localport=<port>]
java.lang.UnsupportedOperationException: Deserialization not allowed for class com.wily.introscope.spec.agent.beans.autotracing.AgentMetricThresholdTrigger (on <date>)
    at org.kantega.notsoserial.DefaultNotSoSerial.preventDeserialization(DefaultNotSoSerial.java:256)
    at org.kantega.notsoserial.DefaultNotSoSerial.onBeforeResolveClass(DefaultNotSoSerial.java:248)
    at org.kantega.notsoserial.ObjectInputStreamClassVisitor.onBeforeResolveClass(ObjectInputStreamClassVisitor.java:48)
    at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1868)
...

Environment

APM Java Agent

Cause

The problem is is related to a Deserialization Firewall from Adobe AEM.  Firewall is blocking the deserialization of wily agent classes.

Resolution

Add our classes (com.wily.) to the white-list section in Adobe AEM configuration. Consult your Adobe AEM Support Team.