NO LICENSE appears on multiple hubs in Infrastructure Manager after upgrading all secondary hubs to 9.20

book

Article ID: 142783

calendar_today

Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

NO LICENSE messages appear on UIM hierachary pane for multiple hubs even though License information on hub lists license as Perpetual with an expire date of never.

Cause

Most of the hubs can directly communicate with one another and no tunnels are configured between the majority of these hubs.  The primary hub and the remote client hubs had broadcasting disabled, but the "middle tier" connector hubs had broadcasting enabled.  All of these hubs can communicate directly with one another (no firewall in place).  This resulted in corrupted information in the hubs.sds files on the middle tier hubs.

Environment

Release : 9.2.0

Component : UIM - HUB

Resolution

This was corrected by deleting the entries for the problematic hubs from the Hubs tab of the hub probe Configure GUI on the middle tier hubs, then adding entries to the Name Services tab in the primary hub probe's Configure GUI for the problematic hubs and adding an entry for the primary hub to the Name Services tab in the hub probe's Configure GUI for each of the problematic hubs.

Additional Information

It is highly recommended that hub broadcasting be enabled on all hubs in a UIM domain or have hub broadcasting disabled on all hubs.  Mixing the hub broadcast setting in the hub configurations for hubs that can directly communicate with one another, the end result is invalid information in the hubs.sds files.