INTERNALALARM: UNABLE TO GET CPU DATA (TEMPORARILY OUT OF RESOURCES) (change this from Major to Warn)
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INTERNALALARM: UNABLE TO GET CPU DATA (TEMPORARILY OUT OF RESOURCES) (change this from Major to Warn)

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Article ID: 142763

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We keep receiving this alarm from  the robot as severity 'Major'. How to change the severity 'Major' to 'Warning' for this alarm?

Environment

Release : 8.5

Component : UNIFIED INFRASTRUCTURE MGMT

cdm probe

Cause

- Need to decrease the alarm severity for InternalAlarm message.

Resolution

You can use a preprocessing rule and filter on the message /.*<message_string>.*/ and run a LUA script to decrease the severity from a higher level to a Warning.

Example message filter: /.*Unable to get CPU data.*/

1. Open the NAS GUI on the Primary Hub.

2. Select Auto-Operator -> Scripts -> right click and select new script.

3. Add the following and save the new script:

event.level = "2"
return event

NOTE: If you test the script in this window it will fail, so you can ignore that error.

4. Under Auto-Operator -> preprocessing Rules -> right click and select new.

5. Select the following:

- Filter type: custom
- Severity Level: Major (optional)
- Select "NMS Hub Name" and hit F1, select the hub in question. (optional)
- Custom Script: Select the new script you already created.



Note that you can send a test alarm via the nas to make sure the Major alarm you send is decreased to a Warning severity/level.

For example, rt-click in the nas Status Tab window and Send a Test alarm -> InternalAlarm: Unable to get CPU data (error).

The major alarm will be decreased in severity and display as a Warning alarm in the alarm subconsole.