MUX Timesheets warnings for locks " Lock ~prTimeEntry held by user"
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MUX Timesheets warnings for locks " Lock ~prTimeEntry held by user"

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Article ID: 142749

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

We are seeing warning messages in app-ca.log when using MUX timesheets (User ID can vary):

WARN  2020-01-06 14:23:58,977 [https-jsse-nio2-2443-exec-5] niku.xql2 (clarity:admin:17981279__991BA6FA-3E10-4199-BF2C-3D55DA733464:PPM_REST_API) Lock ~prTimeEntry held by user 5000000 requested by user 5000000

WARN  2020-01-06 14:23:59,081 [https-jsse-nio2-2443-exec-5] niku.xql2 (clarity:admin:17981279__991BA6FA-3E10-4199-BF2C-3D55DA733464:PPM_REST_API) Lock ~prTimeEntry held by user 5000000 requested by user 5000000

Environment

Release : All supported Clarity releases

Cause

  • This is a normal and expected Warning message, that the timesheet lock is retained.
  • The locks have been added to New UX timesheets to avoid duplicate timesheets creation and they will be shown in logs.
  • So a lock is created when the user submits the timesheets to prevent anyone/anything else from updating it too.
  • The lock will be created on Timesheet creation and may be retained for some time.

Resolution

  • If the user is able to open and submit the timesheet and does not see any issue in UI, we recommend to simply ignore this message.  
  • If you don't want to see this type of warning in the logs, it is possible to reset the logger level to only show level ERROR for those timesheet locks.