Dxdumpdb failed with Datastore cannot be accessed error
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Dxdumpdb failed with Datastore cannot be accessed error

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Article ID: 142686

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Updated On:

Products

CA Directory CA Identity Manager CA Identity Suite SITEMINDER CA Security Command Center

Issue/Introduction

Dxdumpdb failed with the following error message.

    Datastore 'C:\Program Files\CA\Directory\dxserver\data\<dsa name>.db' cannot be accessed

It failed with the same error message when you use the -z option

    Datastore 'C:\Program Files\CA\Directory\dxserver\data\<dsa name>.zdb' cannot be accessed

The db (zdb) file exists in dxserver\data directory.

Environment

CA Directory 12.x, 14.0, 14.1, 14.1 CR1 on Windows platform

Cause

This is a known issue which is recorded in bug DE440130.
The problem only happens on Windows platform when dxgrid-db-size is set to more than 4000 (4GB). 

Resolution

This issue has been permanently fixed in 14.1 SP2 which is available from the Broadcom Support Portals Download center.  (You must be logged into the Support Portal for this link to work correctly)