Dxdumpdb failed with Datastore cannot be accessed error

book

Article ID: 142686

calendar_today

Updated On:

Products

DIRECTORY CA Identity Manager CA Identity Suite SITEMINDER SINGLE SIGN ON - LEGACY CA Directory

Issue/Introduction

Dxdumpdb failed with the following error message.

    Datastore 'C:\Program Files\CA\Directory\dxserver\data\<dsa name>.db' cannot be accessed

It failed with the same error message when you use the -z option

    Datastore 'C:\Program Files\CA\Directory\dxserver\data\<dsa name>.zdb' cannot be accessed

The db (zdb) file exists in dxserver\data directory.

Cause

This is a known issue which is recorded in bug DE440130.
The problem only happens on Windows platform when dxgrid-db-size is set to more than 4000 (4GB). 

Environment

CA Directory 12.x, 14.0, 14.1, 14.1 CR1 on Windows platform

Resolution

This issue has been permanently fixed in Service Pack 1 for 14.1 which was released in June of 2020 and is available from the Broadcom Support Portals Download center.