Service Desk Manager integration with Spectrum not working

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Article ID: 142662

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Updated On:

Products

CA Service Desk Manager SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Desk Manager - Mobile Application CA Service Desk Manager - Xtraction

Issue/Introduction

Receiving Error: Unable to connect to Service Desk web service on server *hostname*. Check Service Desk configuration information.

Verified the ports are accessible.

Cause

Service Desk Manager Tomcat may not be running. An example of an error message in the pdm_tomcat.log file from Service Desk Manager:

*Time* org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["https-jsse-nio-8443"]
*Time* org.apache.coyote.AbstractProtocol init
SEVERE: Failed to initialize end point associated with ProtocolHandler ["https-jsse-nio-8443"]
java.net.BindException: Address already in use: bind

Environment

Release : 17.1

Component : Service Desk Manager

Resolution

Ensure that Tomcat is fully functional. In this example Tomcat failed to start due to a port conflict. The conflict needs to be resolved to restore Tomcat functionality.

Sometimes a restart of Tomcat may be required, this can be accomplished by running these commands from a prompt on the server:

pdm_tomcat_nxd -c stop

pdm_tomcat_nxd -c start

Additional Information

Steps to enable Tomcat debug logging are located here. This may be required if Tomcat is fully functional, and the Tomcat logs don't provide clues as to the cause of the problem.

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/business-management/ca-service-management/17-1/troubleshooting/troubleshooting-ca-service-desk-manager/tomcat-logging.html