Support of Wildfly 14.x and Azure for web deployment

book

Article ID: 142593

calendar_today

Updated On:

Products

CA Gen CA Gen - Workstation Toolset CA Gen - Host Encyclopedia CA Gen - Run Time Distributed

Issue/Introduction

Trying to deploy applications in Azure Linux/Wildfly (version 14.0) environment and would like to know if this environment is certified for Gen.

Environment

Release : 8.6

Component : CA Gen Run Time, Distributed

Resolution

Regarding Azure, this is currently not supported/tested with Gen r8.6.  The recommendation for support of Azure is to submit an Ideation (Enhancement Request) on our Gen Communities pages for further review.  Other Gen customer community can them comment and vote on this Ideation request.   The Gen Communities pages is located at: 

https://community.broadcom.com/mainframesoftware/communities/communityhomeblogs?CommunityKey=4182c217-4789-4997-8f22-87de25983f6e

From here you can Login or Register, and select the 'Ideation' link at the top of the webpage,  in order to 'Add' an Ideation for review.  

 

Regarding Azure, this is currently not support/tested with Gen r8.6 (as of Jan 2020).  The recommendation for support of Azure is to submit an Ideation (Enhancement Request) on our Gen Communities pages for further review.  The Gen Communities pages is located at: 


https://community.broadcom.com/mainframesoftware/communities/communityhomeblogs?CommunityKey=4182c217-4789-4997-8f22-87de25983f6e

 

Regarding Wildfly 14.0, in looking at our Gen r8.6 Technical Requirements, we certified/test Gen r8.6 with Wildfly v10.1:


https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-mainframe-software/devops/ca-gen/8-6/technical-requirements/third-party-software-version.html 

 

Here is additional information regarding Wildfly, after reviewing with the Gen Sustaining Team:

Wildfly v10.1 (Gen certified):  Supports Java 8 with Java EE7.
Wildfly v14 (not Gen certified): Supports Java 8 with Java EE8.
Wildfly v15 (not Gen certified): Supports Java 8 & 11 with Java EE8.

Currently, we don't have plans to certify Wildfly v14.  Since we certified with Wildfly v10.1, it is believed customers should be able to use v14.0.
Additionally, we made an effort to certify with JBoss EAP 7.1 in order to support Java 11.  Note that JBoss EAP and Wildfly  are practically the same, with our current focus remaining with EAP certifications.   Regarding Wildfly (v14 or future versions), we would suggest submitting an Ideation (as described above) for specific certification of Wildfly v14.