MTC Connector fail to start on SOI Manager
search cancel

MTC Connector fail to start on SOI Manager

book

Article ID: 142558

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

After restarting SOI Manager services, the MTC connector fail to start and it shows as "Offline" in UI

Environment

Service Operations Insight (SOI) Manager - 4.x

Cause

Following exceptions found in \SOI\jsw\logs\SAM-IntegrationServices_wrapper.log and the file size is Zero KB

Reading config file: D:\CA\SOI\resources\Configurations\mtc_<ServerName>.xml
[Fatal Error] :-1:-1: Premature end of file.
Error parsing configuration file!! 
Error parsing configuration file!! 
org.xml.sax.SAXParseException; Premature end of file.

Resolution

The MTC Connector configuration file was corrupt and file size is 0 KB

Follow these steps to fix this problem

1) Stop "CA SOI Integration Services" on the Manager server

2) Copy "\SOI\resources\Configurations\mtc_<ServerName>.xml from backup or copy it from another SOI manager and make necessary changes like Hostname, password etc

3) Start "CA SOI Integration Services"