Unable to upgrade 11.4 agent to 11.5

book

Article ID: 142434

calendar_today

Updated On:

Products

CA Workload Automation Agents CA Workload Automation Agent

Issue/Introduction

Unable to upgrade agent from 11.4 TO 11.5 using the following syntax

./setup.bin -i silent -DACCEPT_EULA=ACCEPT -DAGENT_UPGRADE_PATH=<path to existing agent directory> [-DUPGRADE_BACKUP_LOCATION=<absolute path to backup directory>]

It fails with the following error

Custom Action:            cybermation.iainstaller.library.CybFatalException
                          Status: FATAL ERROR
                          Additional Notes: FATAL ERROR -     class cybermation.iainstaller.library.CybFatalException FatalInstallException: JVM_PATH for upgrade is invalid! (/tmp/install.dir.24301)

 

Cause

The 11.5 AGENT is bundled with OpenJDK and not with JRE as with the previous versions.

Support for AdoptOpenJRE – On platforms where the agent install provided its own bundled Java runtime (Windows, Linux), there is now an option to install the bundled Java runtime (AdoptOpenJRE8) or specify an alternate Java runtime like Oracle JRE.

CA Workload Automation Agents R11.5-0000 General Availability Announcement

 

Environment

Release : 11.5

Component : CA Workload Automation System Agent

Resolution

We need to point to JRE that you will using with the 11.5 agent using the upgrade.properties file which is provided with the iso image.

JVM Location  (Required if USE_BUNDLED_JVM=FALSE)              
                                                                 
JVM_DOT=<Absolute path to a pre-installed JRE location>       
JVM_PATH=<Absolute path to the JRE's JAVA VM executable>      
                                                                 
Examples:                                                     
Linux, Linux PPC 64, Linux PPCLE 64, AIX, zLinux, Solaris,    
HP UX, HP NonStop                                             
JVM_DOT=/etc/alternatives/jre_1.8.0                           
JVM_PATH=/etc/alternatives/jre_1.8.0/bin/java                 
                                                                 
Windows                                                       
JVM_DOT=C:\\Program Files\\Java\\jre1.8.0_221                 
JVM_PATH=C:\\Program Files\\Java\\jre1.8.0_221\\bin\\java.exe 
                                                                 
These properties are ignored on IBM iSeries    

Please note that you cannot point to the JRE in the agent location which will be upgraded. It needs to exist elsewhere in the filesystem.