API Portal Legacy: How to update the Portal certificates to reconnect the Gateway after certificate update

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Article ID: 142404

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Updated On:

Products

CA API Gateway CA API Developer Portal

Issue/Introduction

After updating the API Gateway's default certificate the API Portal Legacy may be unable to connect to the Gateway using API Explorer and other features may be impacted. Usually a NullPointerException will also be seen such as the following:

java.lang.NullPointerException
at com.l7tech.apiexplorer.ssl.SSLUtils.dumpCert(SSLUtils.java:69)
at com.l7tech.apiexplorer.ssl.SSLSocketFactoryProviderImpl.addPrivateKey(SSLSocketFactoryProviderImpl.java:69)
at com.l7tech.apiexplorer.ssl.SSLSocketFactoryProviderFileImpl.<init>(SSLSocketFactoryProviderFileImpl.java:36)
at com.l7tech.apiexplorer.SSLUtility.getSslSocketFactoryProvider(SSLUtility.java:53)
at com.l7tech.apiexplorer.SSLUtility.wrapClient(SSLUtility.java:81)
at com.l7tech.apiexplorer.ApiExplorer.processRequest(ApiExplorer.java:174)

Cause

This will occur when a certificate is updated on the Gateway but not updated with the Portal too.

Environment

This impacts all API Portal Legacy versions - 3.5 and older.

Resolution

To resolve, simply rerun the config_portal.sh script and specify the new new certificate. This will reconfigure the portal with the updated certificate. See the link below in the Additional Information section to view the product documentation which references the script.

Additional Information

Documentation on setting up the API Portal Legacy: https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-api-management/api-portal-legacy/3-5/set-up-the-api-portal/install-the-api-portal-appliance/2-configure-the-initial-settings-of-the-api-portal-appliance.html