Clarity PPM New UI - Budget Plan creation: "Submit Option" is set to "Merge" even when the default is set to "Replace"

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Article ID: 142388

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Following are the steps to reproduce this issue:
1. Navigate to the Cost Plan object (Administration -> Objects -> {Cost Plan})
2. Open the "Submit Option" attribute
3. Set the "Default" field to "Replace"

Following are to be performed in the Classic UI:
4. Create a new project (Home -> Projects)
5. Provide Department and Location to the newly created project ({Project} -> Settings {Sub page})
6. Create a new Cost Plan ({Project} -> Financial Plans {tab})
7. Submit the newly created Cost Plan for approval as budget plan (Actions {from Cost Plan list view} -> Submit Plan of Record for approval)
8. Provide a Plan ID in the "Submit For Approval" page
9. Navigate to submitted Budget Plan and approve it (Budget Plans {sub page})
10. Navigate back to Cost Plans sub page. Create a new Cost Plan and submit it for approval again, as in Step 7
11. Notice that the "Submit Option" field is set to "Replace"

Following are to be performed in the New UI:
12. Now open the same project in the New UI
13. Navigate to Financials tab
14. Display the List view by selecting the icon from the top left corner of the page
15. Submit the Plan of Record for approval
16. Notice that the "Submit Option" field is set to "Merge"

Expected Result: In Step 16, the "Submit Option" field is defaulted to "Replace"
Actual Result: In Step 16, the "Submit Option" field is set to "Merge"

Cause

Due to a Defect with ID DE52475.

Environment

Version: 15.7.1

Resolution

The defect is currently being reviewed by Product Management.