IM Log error Property endPointName doesn't exist
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IM Log error Property endPointName doesn't exist

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Article ID: 142386

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

The CA Identity Manager (IM) Server Log records errors like the one below:

 

2019-12-30 12:30:11,570 WARN  [com.ca.iam.model.impl.IAMObjectImpl] (Thread-2353 (HornetQ-client-global-threads-1876441290)) Property endPointName doesn't exist in definition of eTInclusionObject for endpoint type CommonObjects, check calling code

Environment

Release : 14.x

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

Within the LDAP directory for the provisioning server there are DYN Policies set for each endpoint. Out of the box there are some missing policies until the endpoint is created. The DYN Policy is what contains the eTID/inclusion for the endpoint, when this is missing then it is possible for IDM to throw the benign error message.

Resolution

These errors are expected in this scenario and there is no resolution.