snmpcollector 4.0+ includes incorrect samplerate value in QOS/ Breaks Static TOT
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snmpcollector 4.0+ includes incorrect samplerate value in QOS/ Breaks Static TOT

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Article ID: 142322

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

snmpcollector 4.03+ includes the incorrect samplerate value in the QOS message and Breaks TOT threshold calculation

Example:
QOS Message for 1 min poll rate includes a samplerate of 1800 (This should be 60)
QOS Message for 5 min poll rate includes a samplerate of 9000 (This should be 300)
QOS Message for 10 min poll rate includes a samplerate of 18000 (This should be 600)

The incorrect samplerate is seen in DrNimbus and in the RN_QOS* table

Environment

snmpcollector 4.03+ 

Cause

  • snmpcollector smallest poll interval value defaults to 30 seconds

Resolution

Add below key in snmpcollector probe's setup section via raw configure:

SMALLEST_POLL_INTERVAL = 1

Steps:

1. Deactivate the snmpcollector probe
2. Open raw configuration of the probe in Admin Console.
3. Go to setup section
4. Add new key/value pair as shown
5. Save the changes
6. Activate probe

Samplerate value in QOS Message for 1 min poll rate should now be 60
Samplerate value in QOS Message for 5 min poll rate should now be 300
Samplerate value in QOS Message for 10 min poll rate should now be 600

NOTE:

The samplerate value in the QOS message is stored in the database (RN_QOS_DATA_* tables)  and not visible through USM reports.

Use the following queries to check the samplerate value for a given QOS and Device

1. Select a device that is being monitored by the snmpcollector probe.

2. Replace 'devicename' with any device being monitored by the snmpcollector probe and run the query to identify its table_id and RN_QOS_DATA_* table.

In this example, we are using QOS_AVAILABILITY_AVAILABILITY monitor.

select table_id, r_table from s_qos_data where source = 'devicename' and qos = 'QOS_AVAILABILITY_AVAILABILITY' 

3. Take the table_id and RN_QOS_Data_* table values and run the query below to check the samplerate column

To see current samplerate values:
select * from  RN_QOS_DATA_#### where table_id = #### order by sampletime desc;

To see samplerate values prior to adding the SMALLEST_POLL_INTERVAL =1 snmpcollector key
select * from RN_QOS_DATA_#### where table_id = #### order by sampletime asc;

Additional Information

You may also want to clear out the following, to clean up the bogus alarms:

- deactivate nas on the snmpcollector machine
- deactivate alarm_enrichment on the snmpcollector machine
- delete the following on the snmpcollector machine:

C:\Program Files (x86)\Nimsoft\probes\service\nas\alarm_enrichment\db\TOTAlarmCandidateDb.ser
C:\Program Files (x86)\Nimsoft\probes\service\nas\alarm_enrichment\db\TOTAlarmCandidateDb.ser.p

- activate alarm_enrichment on the snmpcollector machine
- activate nas on the snmpcollector machine

Clear existing alarms from within the alarm console.