CA IDM 14.3 Standalone connector Xpress install fails

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Article ID: 142212

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

Extracting and installing connector xpress from the D Drive Fail.  

In the logs you will see the following errors:


(Dec 19, 2019 2:39:46 PM), Install, com.ca.etrust.install.admin.connectorserver.ConfigureConXP, err, An error occurred and product installation failed.  Look at the log file C:\Users\idmadmin\AppData\Local\Temp/im_connector_xpress_install.log for details.
(Dec 19, 2019 2:39:46 PM), Install, com.ca.etrust.install.admin.connectorserver.ConfigureConXP, err, ProductException: (error code = -1; message="IO Exception executing command. Reason: java.io.IOException: Cannot run program "C:\Program Files (x86)\CA\Identity Manager\Connector Xpress\jvm\bin\keytool.exe": CreateProcess error=2, The system cannot find the file specified")
STACK_TRACE: 17
ProductException: (error code = -1; message="IO Exception executing command. Reason: java.io.IOException: Cannot run program "C:\Program Files (x86)\CA\Identity Manager\Connector Xpress\jvm\bin\keytool.exe": CreateProcess error=2, The system cannot find the file specified")

Cause

There was an issue running the Connector Xpress installer from the D Drive. The installation files were not being copied to the required locations.

Environment

Release : 14.3

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Resolution

Extract and run the Connector Xpress installer from the C Drive.

You are able to select a custom installation and point to the D Drive successfully.