How to promote a pingable device to manageable in CA Performance Management
search cancel

How to promote a pingable device to manageable in CA Performance Management

book

Article ID: 142139

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

I need to change some devices that are showing as "Pingable Device" to switches, router, etc.

Environment

Dx NetOps Performance Management 3.7

Cause

A pingable device is a device that can be reached via ICMP, but not SNMP.

Resolution

So to promote the pingable to its actual type you need to:

1) Make sure the device can be reached via SNMP from the data collector server. If you are unsure the sapwalk tool can be used:

On CAPM 3.6 or later, sapwalk is already installed on each Data Collector at:

/opt/IMDataCollector/scripts/sapwalk2

Note that your exact path may vary if you did not install the Data Collector in the default location.

If needed, sapwalk2 can be downloaded from:

https://ftp.broadcom.com/user/downloads/pub/CA-SPECTRUM/Tools/sapwalk2/

Log in using:
Username: Anonymous
Password:

Here is some example syntax:

sapwalk2 -i -v v2c -s 1.3.6. -c -o device_mib.walk

Usage: sapwalk2
         -i  ip_address
         -v  snmp_version(v1/v2c/v3)
         -s  startoid
         <-c  community for v1/v2c           >
         <-u  username  for v3               >
         <-l  seclevel  (nAnP/AnP/AP) for v3 >
         [-xt auth type (MD5/SHA) for v3     ]
         [-xa auth password for v3           ]
         [-xp priv password for v3           ]
         [-xn ctxtname  for v3               ]
         [-xe priv type (DES/3DES/AES128/AES192/AES256)for v3  ]
         [-xi ctxtid    for v3 (will discover if not specified)]
         [-e  engineid  for v3 (will discover if not specified)]
         [-t  timeout(msec)                  ]
         [-r  retries                        ]
         [-f  compare (0/1)                  ]
         [-p  snmpport                       ]
         [-d  sleep_bet_req(msec)            ]
         [-m  maxlexerrors                   ]
         [-z  samples:delay_in_msec: for ratecomputation of counter/gauge variables]
         [-o  walkoutput filename            ]
         [-n  max num of variables to learn  ]
         [-xf filename containing oids to be excluded(one per line) ]
         [-xr guestimate max rows            ]
         [-xs source ip                      ]
         [-xy source endpoint (port)         ]
         [-xv bridge / or vlanstartoid for auto vlan learn]
         [-xl save timestamps (0/1)          ]
         [-xz timestamp threshold (def=10sec)
         [-b  getbulk flag (0/1)             ]


2)  You have an SNMP Profile configured with the proper credentials/port for the SNMP agent on the device:

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/performance-management/3-7/building/snmp-profiles.html

3) And you run a discovery of the device with a profile that contains that SNMP profile:

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/performance-management/3-7/building/discovery.html#concept.dita_c2c45258cc99dd66f16820adfcfb49413d9a73ab_DiscoverDevices