Device showing in NetOps Portal but not in Data Aggregator
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Device showing in NetOps Portal but not in Data Aggregator

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Article ID: 142077

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

I have a device that is in the Default Domain global collection group in Spectrum. 
It shows in CAPC but does not show in monitored inventory in the DA. 
I've done Full Synchronization on Spectrum Data Source and Full Synchronization on DA data source a few times but no change.  Need assistance to get this device into the DA.

Environment

Release : 3.7, 20.2, 21.2

Cause

ICMP blocked on the device.  As a result, it shows as "Inaccessible" in the discovery profile results

Resolution

  • Create a discovery profile for the device and and click on the "Advanced" tab. 
  • From there uncheck "Use ICMP"  under the "ICMP Discovery" section. 
  • Then rediscover the device. 

It should now discover fine because we no longer attempt ICMP connectivity to the device.  Instead, we just try SNMP. 

If the device still shows as Inaccessible on subsequent discovery attempts, utilization of tcpdump or other packet analysis tools will need to be used to determine the communication break as even SNMP communication is not successful.


Additional Information

It is recommended to create a discover profile specifically for devices that do not respond to ICMP as described above as this should only be used where needed.

Normally when the ping fails the SNMP discovery is not done. When "Use ICMP" is disabled, DX Netops Performance Management will make SNMP requests to
all addresses in the discovery profile, which can extend the time the profile discovery takes, as it will need to wait through the SNMP timeouts and retries for each address.