Rally: Portfolio Items: User receiving "Whoops" message and is unable to see anything on the Portfolio Items Page
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Rally: Portfolio Items: User receiving "Whoops" message and is unable to see anything on the Portfolio Items Page

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Article ID: 142063

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Updated On:

Products

Rally On-Premise Rally SaaS

Issue/Introduction

The user is unable to see anything on the Portfolio Items page. Instead the page may be stuck loading, or display a "Whoops" error.

Environment

Release : SAAS

Component : AGILE CENTRAL

Cause

When the Portfolio Items page won't load or clicking on the filter icon does not bring up the filters, it is usually due to a corrupt filter setting that prevents the board from loading. Filters are saved as a Preference on a per-user basis. To clear the potentially corrupt filter setting, you can delete the filter preference.  Each user experiencing this issue will need to walk through the process to clear their own preference. 

 

Resolution

  1. On your dashboard or a custom page, add the "Custom HTML" app from the App Catalog.
  2. Paste the Preference Deleter code from this URL into the HTML section of the Custom HTML app. and <Save>.
  3. You will be prompted to enter the Preference Name, enter: data-table-default/-200049
  4. Make sure there are no beginning or ending spaces in the entry and click Find Preference.
  5. For each preference that is found, please click the Delete button and confirm Delete Preference Permanently.
  6. Once you have deleted all preferences, click the Find Preference button again and ensure that you see a popup box titled Preference Not Found.
  7. Clear cache and logout immediately (don't navigate to any other page, so as not to save any additional preferences).
  8. Now when you login the filter is gone from the Portfolio Kanban Board and your board should load.

If the above troubleshooting doesn't work, please try deleting the portfolio-items-inline-filter