Duplicate Inventory records for vCenters in vmware probe
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Duplicate Inventory records for vCenters in vmware probe

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Article ID: 142045

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

This article addresses the following scenarios: 

  • Duplicate records for vCenters in the Operator Console (OC) Inventory have been identified. This may cause also duplicate models to be imported into Spectrum. One entry looks like it's coming from the UIM Robot and another one from the vmware probe.

  • After vCenter migration to a new server, now we have lots of duplicate entries in the inventory

Environment

  • DX UIM 23.4.*
  • vmware any version

Cause

  • discovery_server correlation causes this scenario. Prospects that have a different VirtualID or VirtualManagerId do not match. This creates a decorrelation (duplicate) even though the device has the same IP and hostname. 

    The correlation rules are listed in the 'unmatch_on_any' rule in the discovery server rules: 

    "RobotInstanceId, SysName, VirtualID, VirtualManagerId, defined:AllCorrelationNames, defined:MacAddresses

 

Example:

  1. On cs_id 84xxx: (Virtual machine/Robot)

    <attributes key="VirtualID" value="500b9845-xxxx-90a2-664d-42xxxxeb66e8"/>

  2. On cs_id 560xxx: (vCenter)

    <attributes key="VirtualID" value="89e2c349-xxxx-4f96-b7c6-a5dxxxxe7977"/>

Resolution

  1. Confirm the cause of the duplication: 

    --Run the following querying changing the cs_id from 2 servers in the query below. (123, 456) 

    select * from CM_DEVICE dev inner join CM_DEVICE_ATTRIBUTE attr on dev.dev_id=attr.dev_id where cs_id in (123, 456) order by cs_id,attr.dev_id,attr.dev_attr_key

             --Analyze the results and identify if any of the attributes from the devices are  listed in the unmatch_on_any discovery rules.


  2. Based on the results from the query, to resolve this issue: 
  • If the VirtualID, VirtualManagerId duplication for the same server is caused by vCenter migration (meaning that the "old" entry is static and no longer valid)

    • remove (Delete) the duplicated devices from OC Inventory, e.g., select the 2 devices that are duplicated and delete them "without clearing out the QOS and alarms"
    • then wait for automatic rediscovery
    • VMWARE and controller will automatically rediscover the server from the new virtualManagerid only

  • If there is a real VirtualID or VirtualManagerId duplication
     
    • examine the <rules> section in the discovery_server.cfg
    • remove VirtualID or  VirtualManagerId  from all of the 'unmatch_on_any' rules
    • save the file then cold start the discovery_server, it should resolve the duplicates