MSP Project performance issues due to tasks with start/finish dates far out in past or future
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MSP Project performance issues due to tasks with start/finish dates far out in past or future

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Article ID: 142011

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The Microsoft Project (MSP) project becomes non-responsive once you start doing anything in the project (like scrolling) after opening from Clarity. Then it just closes down. Or, the project may not get fully loaded and stops responding. It takes an extremely long time whether it finally gets loaded or just crashes out. This issue may be seen on just one project. 

Cause

This can happen if there is a large project duration (such as the project running from 2010 to 2020) along with other factors such as a large number of baselines.

Resolution

Check for any tasks that may be set far out in the past and future, and bring the dates in if they are incorrect. One way to check quickly for any start/finish dates that are far out in past/future is to:

  1. Click on the arrow in the Start and Finish Date column headers in MSP
  2. Then scroll through the filter section and check the dates

Additional Information

For other performance tips, see MSP Integration performance best practices.

See also MSP opening projects - known issues with Clarity.