MSP Project crashing/performance issues on one project due to tasks with start/finish dates far out in past or future

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Article ID: 142011

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Updated On:

Products

STARTER PACK-CLARITY PPM Clarity PPM SaaS

Issue/Introduction

Symptoms observed:

  1. The Microsoft Project (MSP) project becomes non-responsive once I start doing anything in the project (like scrolling) after opening from Clarity PPM. Then it just closes down.
  2. Or, the project may not get fully loaded  at all and stops responding. 
  3. It takes an extremely long time whether it finally gets loaded or just crashes out.

 

Cause

This can happen if there is a large project duration (such as the project running from 2010 to 2020) along with other factors such as a large number of baselines

 

Environment

Release : All Supported Releases

Component : CA PPM SAAS MICROSOFT PROJECT (MSP)

Resolution

  1. Check for any tasks that may be set far out in the past and future, and bring the dates in if they are incorrect.
  2. One way to check quickly for any start/finish dates that are far out in past/future is to:
  • Click on the arrow in the Start and Finish Date column headers in MSP
  • Then scroll through the filter section and check the dates

For other performance tips, see 13911 - In MSP, what are some Best Practices to prevent Performance Issues when integrating with Clarity PPM?

Additional Information

  • See the following master KB for all known issues opening projects in MSP:

    • 138671- List of Clarity PPM KB articles related to issues opening projects in MSP
  • Reference KB000071385 - CA PPM and MSP integration - List of Knowledge Documents
  • Reference KB000015956 - CA PPM and MSP integration known defects - Support Technical Document Index
  • See KB 141061 - How to search for known Clarity PPM Issues using Self Service