Cannot see users in IDM after 14.3 upgrade

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Article ID: 141987

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

IDM was upgraded from 14.2 to 14.3 following the steps outlined in the upgrading to 14.3 documentation: http://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-identity-and-access-management/identity-suite/14-3/virtual-appliance/upgrading-virtual-appliance.html

After completing the upgrade and logging into IDM, only two users are returned in search results for users, where all users were returned prior to the upgrade.

Cause

The default search field on tasks such as View User, Modify User, etc. had changed from User ID to Login ID. Only two users had Login ID populated so they were the only users returned in search results.

Environment

Release : 14.3

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Resolution

Change the default search field back to User ID in order to see all users in the search results.  To do so:

1. Go to Roles and Tasks > Admin Tasks > Modify Admin Task and select the task to be updated.

2. Click the Search tab.

3. Click the Edit button for the selected Screen Definition.

4. Confirm the Default search filter uses the correct attribute.

5. Click OK, Select and Submit to save any changes.