Service Catalog-Request Status History not available for some requests

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Article ID: 141868

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Some requests' Request Status history show   "No available history". 

Cause

The catalog application's registration name in EEM on the newly upgraded env is different from the one when it was at previous version .

For example ,  the catalog application in 14.1 may be registered as "Service Catalog" ,   during upgrade ,  you may have new catalog application registered as "CA Service Catalog" .  So,  for all those old requests ( which existed    prior to upgrade )  ,  system user was named "CERT-Service Catalog" .  new  catalog 17.2 doesn't know what it is   (  since the new catalog was registered as CA Service Catalog in EEM , and the system user was supposed to be "CERT-CA Service Catalog"  then here ) .  That is the cause of this problem .  

Environment

Release : 17.2 , 17.1 

Component : CA SERVICE CATALOG

Resolution

The example  below assumes that  : before upgrade/migration ,  the catalog application was registered as "Service Catalog" .  After upgrade/migration , the catalog application was registered as "CA Service Catalog"  here . 

 

It will need to change "CERT-Service Catalog"  to  "CERT-CA Service Catalog" in both usm_request_status table   and  usm_request_pending_act_hist table to fix this problem . 

 

As proof of concept ,   You can  do  the following for  one  problem request , for example , the one with request_id  430103

1.

SELECT * FROM usm_request_status WHERE user_id='CERT-Service Catalog' AND request_id='430103'

UPDATE usm_request_status
SET user_id='CERT-CA Service Catalog'
WHERE user_id='CERT-Service Catalog' AND request_id='430103'

 

2.  do the following query to find this request's req_pend_act_id value ,  assuming they  are '348210','348212'  here in this example 

select * from usm_request_pending_action where request_id='430103'

 

3.  and then do the following :

SELECT * FROM usm_request_pending_act_hist WHERE modified_by='CERT-Service Catalog' AND req_pend_act_id IN ('348210','348212')

UPDATE usm_request_pending_act_hist
SET modified_by='CERT-CA Service Catalog'
WHERE modified_by='CERT-Service Catalog' AND req_pend_act_id IN ('348210','348212')

 

from catalog UI ,   you will  see  the above was able to address this  problem for request 430103

 

If the approach above is proved to be correct here, then  you can simply do the following to correct all the requests with this problem :

1.  take a backup of both usm_request_status table   and  usm_request_pending_act_hist table

 

2.  do the following updates   :

UPDATE usm_request_status
SET user_id='CERT-CA Service Catalog'
WHERE user_id='CERT-Service Catalog' 

 

UPDATE usm_request_pending_act_hist
SET modified_by='CERT-CA Service Catalog'
WHERE modified_by='CERT-Service Catalog'