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Update % complete job deadlock errors in bg log

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Article ID: 141829

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Below error is frequently observed in bg-ca.log when Update % Complete job is run. 

ERROR 2019-12-05 15:55:57,429 [Dispatch Update % Complete : [email protected](tenant=clarity)] projmgr.functions (clarity:jobrun:zzzzzz__zzzzzz-zzz-zzz-zzzzzz: Update % Complete) ProjectPercentFunction.eval() exception in project 500343

com.niku.union.persistence.PersistenceDeadlockException: 

SQL error code: 60

Error message: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-00060: deadlock detected while waiting for resource

Executed:

 UPDATE PRTASK

        SET IS_PCT_DIRTY = NULL

        WHERE PRPROJECTID = ?

        AND IS_PCT_DIRTY = 1 

Cause

A deadlock error can indicate another job was running at the same time that may be updating one of the tables the Update % complete job is updating.

Environment

Release : All Supported Releases

Component : CA PPM INTEGRATIONS & INSTALLATIONS

Resolution

1. If this one a one time failure, this error can be ignored
 
2. If it happens more frequently, check the scheduling of the job to see if may need to be adjusted to be run more or less
See the below referenced on techdocs at: Update % Complete Job
  • This job is scheduled to run automatically every 30 minutes, but you can also run this job on demand.
  • For best results, schedule this job to run recurrently at an appropriate interval; for example, every 10 minutes.

3. Check to see what jobs were running at the same time as the error that may updating the same table. 

  • If any jobs were found, it may help to make the job(s)  incompatible if the job continues to generate deadlock errors on a regular basis
  • Note: It's recommended to test any job configuration changes in non production first to make sure that compatibility updates don't cause a backlog of jobs waiting

Additional Information

See 141061 - How to search for known Clarity PPM Issues using Self Service