More button icon of Service Point when Service Desk Manager integrated with Service Catalog is missing due to Year 2038 problem

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Article ID: 141550

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Updated On:

Products

CA Service Desk Manager CA Service Catalog CA Service Management - Service Desk Manager

Issue/Introduction

The "..."/More button icon is missing from the Home page of Service Point. 

Before upgrading from 17.2 RU3 to RU4, the button icon was present and all was working fine. No changes were made to the configuration.

The following screenshot shows the presence of the More button:

 

*** STEPS TO REPRODUCE ***

Environment: CA Service Management 17.2.0.4 Windows environment with Search Server, Service Desk Manager, xFlow and Service Point successfully integrated.


1. Stop the CA Service Management Search Server service.

2. Update the mdb as follows: 

update usm_offering set date_available='2065-12-16 00:00:00.000' where offering_id=10229

Note: Ensure that all other dates in the entries of usm_offering are for the year 2019 or earlier.

3. Rename "C:\Program Files\CA\SC\CASearchServer\elasticsearch-2.1.1\data\ca_es_cluster\nodes\0\indices"; for example, rename it from indices to indices-save01


3. Recreate the "indices" subdirectory; that is, create "C:\Program Files\CA\SC\CASearchServer\elasticsearch-2.1.1\data\ca_es_cluster\nodes\0\indices".


4. Start the CA Service Management Search Server service.


5. Run C:\Program Files\CA\SC\CASearchServer\search\bin\pdm_es_initial_load.bat


6. Check results from step #5:

Search for errors ("Exception") for the execution instance in the log file, C:\Program Files\CA\SC\CASearchServer\search\logs\initial_load.log, that show that the "service_offering" object was not successfully included (in the catalog_index_xxxxxxxxxx).

Note that the absence of the service_offering type in the catalog_index can be confirmed using the Elasticsearch Head google chrome web browser extension.

The initial_load.log file contains error messages starting like the following:

[06:09:37,306][ERROR][importer.jdbc.context.standard][pool-19-thread-1] at fetch: com.microsoft.sqlserver.jdbc.SQLServerException: The datediff function resulted in an overflow. The number of dateparts separating two date/time instances is too large. Try to use datediff with a less precise datepart.
java.io.IOException: com.microsoft.sqlserver.jdbc.SQLServerException: The datediff function resulted in an overflow. The number of dateparts separating two date/time instances is too large. Try to use datediff with a less precise datepart.

7. Re-test starting with step #1 through to step #5 and using the statement below in step #2 instead; confirm that pdm_es_initial_load is successful: 

update usm_offering set date_available='2038-01-19 03:14:07.000' where offering_id=10229 

8. Re-test starting with step #1 through to step #5 and using the statement below in step #2 instead; confirm that the datediff exception error occurs:

update usm_offering set date_available='2038-01-19 03:14:08.000' where offering_id=10229 

Cause

INT result type is not big enough.

See the Additional Information section regarding the "Year 2038 problem".

Environment

Release : 17.2

Component : SERVICE DESK MANAGER

Resolution

Check the date values in the usm_offering table entries. Change any date values that are after "2038-01-19" (yyyy-mm-dd format) to an earlier date.

The defect is logged as product defect DE52224, to be fixed in a future patch and/or version.

Additional Information

For information about the "Year 2038 problem", see https://en.wikipedia.org/wiki/Year_2038_problem 

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