CA APM for SSO Failed to Start

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Article ID: 141445

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

CAWilySiteMinderManager Agent fails to start on prod environment and gets the following errors on the logs.

 [ERROR] [EPAgent] EPAgent failed to start because: Introscope EPAgent has no plugins configured and no network ports enabled. Exiting.
com.wily.introscope.epagent.IllegalConfigurationException: Introscope EPAgent has no plugins configured and no network ports enabled. Exiting.
        at com.wily.introscope.epagent.EPAgent.start(EPAgent.java:310)
        at com.wily.introscope.epagent.EPAgent.main(EPAgent.java:438)
        at com.wily.introscope.api.IntroscopeEPAgent.main(IntroscopeEPAgent.java:55)

 

Cause

An older version of EPAgent v8.0 from the previous CA Siteminder Manager 12.0.4 was still on the system.

Environment

CA APM for SSO 13.2

EPAgent 

Resolution

Remove / or upgrade the existing version of EPAgent 8.0  to EPAgent 10.7 as per the CA for SSO 13.2 Prerequisites.

 

CA APM for SSO 13.2 Installation Prerequisites