Process Analytics Admin will not load. Error: Unable to retrieve UC4 ClearView licence.

book

Article ID: 141411

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine AUTOMIC WORKLOAD AUTOMATION CA Automic One Automation CA Automic Operations Manager CA Automic Oracle

Issue/Introduction

Process Analytics Admin fails to load with the following error:

20191003/095243.883 - U6005000 Exception in loader-process:
20191003/095243.883 - com.uc4.gwa.common.dao.DaoException: Unable to retrieve UC4 ClearView licence.
 at com.uc4.gwa.admin.modules.data.dao.UC4DaoModule.getLicenceDate(Unknown Source)
 at com.uc4.gwa.admin.modules.loader.LoaderModule.run(Unknown Source)
 at com.uc4.gwa.admin.modules.main.MainModule.main(Unknown Source)
 at com.senactive.common.runtime.RuntimeNode.init(Unknown Source)
 at com.uc4.gwa.admin.Main.main(Unknown Source)
Caused by: java.time.zone.ZoneRulesException: Unknown time-zone ID: UTC_TIME_ZONE
 at java.time.zone.ZoneRulesProvider.getProvider(Unknown Source)
 at java.time.zone.ZoneRulesProvider.getRules(Unknown Source)
 at java.time.ZoneRegion.ofId(Unknown Source)
 at java.time.ZoneId.ofWithPrefix(Unknown Source)
 at java.time.ZoneId.of(Unknown Source)
 at java.time.ZoneId.of(Unknown Source)
 at java.time.ZoneId.of(Unknown Source)
 at java.util.TimeZone.toZoneId(Unknown Source)
 at java.time.ZoneId.systemDefault(Unknown Source)

etc.

Cause

Configuration.

Troubleshooting steps:

1. Check Automation Engine database for the ClearView licence by executing the following statement:

SELECT * FROM Uc_Lic WHERE lic_Platform = 'ADD.GWA' OR LIC_Platform = 'ADD.CLEARVIEW'

2. a. If the licences are present - the issue is related to Analytics Database not being able to connect to Automation Engine Database. In this case, the error is misleading since the license is actually present. 

    b. If the licenses are not in the database, contact your Account Director to purchase to licences.

3. If the licences are present, you need to check:

a. admin.db.properties. (Reference: https://docs.automic.com/documentation/webhelp/english/AWA/12.2/DOCU/12.2/AWA%20Guides/help.htm#ProcessAnalytics/Config_PA_Admin.htm?Highlight=Process%20analytics )

b. check Process Analytics Admin Start Parameters (reference: https://docs.automic.com/documentation/webhelp/english/AWA/12.2/DOCU/12.2/AWA%20Guides/help.htm#ProcessAnalytics/PA_AdminStartParameters.htm%3FTocPath%3DAdministering%2520and%2520Configuring%7CAdministering%2520Process%2520Analytics%7C_____7 )

c. Check the version of the drivers for both Process Analytics database and Automation Engine Database based on your version of the databases. (ojdbc .jar driver version for Oracle, and sqljdbcX.jar for SQL) - this is most likely the issue if the configuration is correct. 

Environment

Release : 12.0.X, 12.1.X, 12.2.X, 12.3.X

Component : ANALYTICS ON PREMISE, AUTOMATION ENGINE

Resolution

Check the version of the drivers for both Process Analytics database and Automation Engine Database based on your version of the databases. (ojdbc .jar driver version for Oracle, and sqljdbcX.jar for SQL) - replace the drivers with the ones that are compatible for the version of the DBs.