Clarity PPM upgrade fails with "runuser: may not be used by non-root users"
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Clarity PPM upgrade fails with "runuser: may not be used by non-root users"

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Article ID: 141309

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

When upgrading Clarity, it fails with error message:

12/03/19 2:47 PM (Target) Target "_stop-service" started.
12/03/19 2:47 PM (Echo) service id = bg
12/03/19 2:47 PM (Echo)  servicecmd = service
12/03/19 2:47 PM (ExecTask) runuser: may not be used by non-root users
12/03/19 2:47 PM (UnknownElement) Task "exec" finished with error.
/app/clarity/install.xml:1161: exec returned: 1
        at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:643)
        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:669)
        at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:495)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:292)

Environment

Release : All supported Clarity releases on UNIX OS

Cause

  • This means you have a permission issue with the user you run the upgrade with
  • The user is trying to stop the services and it cannot

Resolution

  • Ensure the user has full access to Clarity folder, also Java and Tomcat directly including permission to execute
  • Check what your configuration for the user is and what is the root user in properties.xml to ensure it's correct
  • We suggest to run the upgrade with the same user that runs Clarity.
  • Also stop and remove services prior to starting the upgrade