Spectrum user cannot login to Active Directory Integrated OneClick Server

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Article ID: 141239

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Updated On:

Products

CA eHealth CA Spectrum

Issue/Introduction

We have users that are able to login to Spectrum with their AD/LDAP account (user), with no issues.  However, we have one individual configured the same that is unable to login.

Cause

Enabling SSORB Security SP will write more to the stdout.log (windows) or catalina.out (linux):

Login for user shows the following:

(http-nio-8080-exec-3) (SecuritySP) - User abc12345 is neither a super user nor an allowed user to login Spectrum

(http-nio-8080-exec-3) (SecuritySP) - Authenticating user with external directory server: abc12345

(http-nio-8080-exec-3) (SecuritySP) -   Getting user by search: sAMAccountName=abc12345

(http-nio-8080-exec-3) (SecuritySP) -   search returned no results, no user found

 

Environment

Release : 10.4

Component : Spectrum Core / SpectroSERVER

Resolution

  • Ensure user who cannot login is nested under the OU that is defined in the LDAP Base DN Settings.
  • Expand LDAP Base DN to include OU that user belongs to and set search sub directories to yes.



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