Task Finished Date changes for non-fixed duration tasks when updating the Start Dates manually

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Article ID: 141228

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Updated On:

Products

STARTER PACK-CLARITY PPM Clarity PPM SaaS

Issue/Introduction

  • When manually changing the start date of a task that is not fixed duration, the finish date automatically adjusts after saving retaining the duration.
  • This happens regardless of whether there is a assignment on the task.

Cause

This is working as expected. The fixed flag is not taken into account in manual task date changes, the fixed flag is used for Auto Scheduling.

Environment

Release : All Supported Releases

Component : CA PPM SAAS PROJECT MANAGEMENT

Resolution

The Fixed Duration setting is used for Auto Scheduling purposes. Manual changes to the Task Dates are independent of the Fixed setting.

So, changing only the start date will move the task forward without changing the duration regardless of whether the task is Fixed Duration or not.

Notes: 

  • In classic PPM or Gantt; you can change both dates at the same time before clicking 'Save' button.
  • See the following documentation for details on the difference between having fixed checked or not (this is in the Open Workbench (OWB) documentation, but applies to the PPM Gantt auto scheduling as well)

 

Additional Information

  • See Edit Task Duration in the Gantt Chart of the documentation regarding interactive changes you see when you edit the task attributes on the Gantt view
  • To submit an enhancement request on this feature or any other Clarity PPM component, see: KB 18799
  • See KB: 141061 for tips on how to optimize use of Self Service for Clarity PPM