Discovery Not traversing v3 strings in AutoDiscovery

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Article ID: 141184

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Updated On:

Products

CA eHealth CA Spectrum

Issue/Introduction

When running discovery on a large range of V3 devices ~30,000, discovery will fail to discover the devices if the correct SNMP V3 profile is not the first profile in the list of V3 profiles. 

Cause

This appears to be caused by the large number of devices in the discovery result set and the discovery is timing out. The following messages can be seen in the catalina.out file:

RouterTask.readResponse() - timeout IP:10.10.10.10 with community string #v3/P:SHA^SHAR0v3#SHAROv3:DES^DESROv3#DESR0v3/39-PT-SNMPv3

Environment

Release : 10.3

Component : Spectrum Core / SpectroSERVER

Resolution

There are a couple things you can try to resolve this issue. 

1. Increase the "Maximum Range Discovery Threads" to 16 and the timeout to 30 seconds in the Advanced Discovery options. This may cause discovery to take longer to complete. 

2. Break up the discovery ranges into multiple discovery configurations and run the smaller discovery ranges to prevent this issue from occurring.