Microsoft JDBC Driver compatablity for SQL Server

book

Article ID: 141178

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation Agent CA Workload Automation AE

Issue/Introduction

Does the Autosys DB plug-in support  Microsoft JDBC Driver 7.4 for SQL Server?

As per documentation it says "You will have to extract a driver that is typically called sqljdbc4.jar. Contact your Database Administrator for more information."

Environment

Release : 11.3.6

Component : CA Workload Automation Database Agent

Resolution

The jdbc driver should match the JRE version being used. 
For example: If the customer intends to use Microsoft jdbc driver 7.4 version, then they would need to pick mssql-jdbc-7.4.1.0.jre8,  this requires JRE of 8 and supports the JDBC 4.2 API.
However, sqljdbc4.jar. would still work with the database plugin but note that it will not have the newer features.