NCM config backup failures

book

Article ID: 141154

calendar_today

Updated On:

Products

CA eHealth CA Spectrum

Issue/Introduction

Several devices where NCM config backup fails with this message:

Configuration Manager - Capture failed with Primary communication mode SNMP/TFTP for host running configuration file from device <device> of type SwCiscoIOS on landscape misha initiated by user System. Specific error: Unknown Failure.

 

Dec 03, 2019 09:57:01.513 - com.aprisma.spectrum.scmd.ScmService.debugging set to max
Dec 03, 2019 09:57:08.237 -
java.lang.ArrayIndexOutOfBoundsException: 1202
        at com.aprisma.spectrum.scmd.NCMFileDifference.isInteresting(NCMFileDifference.java:960)
        at com.aprisma.spectrum.scmd.NCMFileDifference.getDiffEx(NCMFileDifference.java:504)
        at com.aprisma.spectrum.scmd.NCMFileDifference.getDiffResultsImplEx(NCMFileDifference.java:260)
        at com.aprisma.spectrum.scmd.NCMFileDifference.getDiffResults(NCMFileDifference.java:181)
        at com.aprisma.spectrum.scmd.ScmServiceImpl.diff(ScmServiceImpl.java:1535)
        at com.aprisma.spectrum.scmd.corba.SpectrumCMPOA._invoke(SpectrumCMPOA.java:206)
        at com.aprisma.spectrum.scmd.corba.SpectrumCMPOA._invoke(SpectrumCMPOA.java:70)
        at com.inprise.vbroker.poa.POAImpl.invoke(Unknown Source)
        at com.inprise.vbroker.poa.ActivationRecord.invoke(Unknown Source)
        at com.inprise.vbroker.GIOP.GiopProtocolAdapter.doRequest(Unknown Source)
        at com.inprise.vbroker.IIOP.ServerProtocolAdapter.doRequest(Unknown Source)
        at com.inprise.vbroker.GIOP.GiopProtocolAdapter.dispatchMessage(Unknown Source)
        at com.inprise.vbroker.orb.TPDispatcherImpl$TPDispatcher.run(Unknown Source)
        at com.inprise.vbroker.orb.ThreadPool$PoolWorker.run(Unknown Source)
Dec 03, 2019 09:57:09.394 -
java.lang.ArrayIndexOutOfBoundsException: 1202
        at com.aprisma.spectrum.scmd.NCMFileDifference.isInteresting(NCMFileDifference.java:960)
        at com.aprisma.spectrum.scmd.NCMFileDifference.getDiffEx(NCMFileDifference.java:504)
        at com.aprisma.spectrum.scmd.NCMFileDifference.getDiffResultsImplEx(NCMFileDifference.java:260)
        at com.aprisma.spectrum.scmd.NCMFileDifference.getDiffResults(NCMFileDifference.java:181)
        at com.aprisma.spectrum.scmd.ScmServiceImpl.diff(ScmServiceImpl.java:1535)
        at com.aprisma.spectrum.scmd.corba.SpectrumCMPOA._invoke(SpectrumCMPOA.java:206)
        at com.aprisma.spectrum.scmd.corba.SpectrumCMPOA._invoke(SpectrumCMPOA.java:70)
        at com.inprise.vbroker.poa.POAImpl.invoke(Unknown Source)
        at com.inprise.vbroker.poa.ActivationRecord.invoke(Unknown Source)
        at com.inprise.vbroker.GIOP.GiopProtocolAdapter.doRequest(Unknown Source)
        at com.inprise.vbroker.IIOP.ServerProtocolAdapter.doRequest(Unknown Source)
        at com.inprise.vbroker.GIOP.GiopProtocolAdapter.dispatchMessage(Unknown Source)
        at com.inprise.vbroker.orb.TPDispatcherImpl$TPDispatcher.run(Unknown Source)
        at com.inprise.vbroker.orb.ThreadPool$PoolWorker.run(Unknown Source)

 

 

Cause

This can be caused by corrupt models in Spectrum.  The previously stored configuration likely is corrupt.

Resolution

Remove the previous configuration from Spectrum.

This can be found via locator or on the Configuration Manager tab.

Capture a new configuration and a new model/base configuration will be stored.

Future diffs and captures should succeed.