UIM - qos_processor does not start after upgrade to 9.02 / 9.2 (corrupt checksum errors)

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Article ID: 141113

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Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

After upgrading UIM to 9.02 and to 9.2 the qos_processor_probe does not start. The qos_processor log shows corrupt checksum errors as below: 

lug 01 13:09:24:518 [Qos Monitor Loader, qos_processor] Loaded monitor (QOS_INTERFACE_UTILIZATIONOUT with corrupt checksum: F7D68C5931577E6E154F7632F7F168B26A546906 (loaded) BC2D694DF9ACD5221265B9C6A6AE1DFF48FE0EAD (computed)
lug 01 13:09:24:518 [Qos Monitor Loader, qos_processor] Loaded monitor (QOS_INTERFACE_PCTDISCARDSIN with corrupt checksum: BE0C36916BF2E61BABE33D531700EA5A06E89254 (loaded) 3CCFD9656FE42A4D8FC70E49FDA70200189A3ABB (computed)
lug 01 13:09:24:518 [Qos Monitor Loader, qos_processor] Loaded monitor (QOS_INTERFACE_OPERSTATUSPOLLABLE with corrupt checksum: 95E02537D5DB6E4DDC99C55C6200160DA5DFCED0 (loaded) 63C5EC688F30BA5A82D4FEEB8902F9D969F1F88B (computed)

[...]

Cause

UIM 9.x introduces new hashes for improved security

Environment

Release : 9.2.0 / 9.02

Component : UIM - QOS_PRROCESSOR 9.10

Resolution

To resolve this issue, follow the 2 steps below:

 

1. update the checksum value by executing the below query. 

 

 

update qos_data

set checksum = CONVERT(VARCHAR(41),HashBytes('SHA1', convert(varchar(1024),

CONCAT(qos_data.qos,'#',qos_data.source,'#',qos_data.target,'#',qos_data.origin))),2)

FROM S_QOS_DATA qos_data

INNER JOIN S_QOS_DATA T on qos_data.table_id = T.table_id

        and T.checksum!=CONVERT(VARCHAR(41),HashBytes('SHA1', convert(varchar(1024),

CONCAT(qos_data.qos,'#',qos_data.source,'#',qos_data.target,'#',qos_data.origin))),2); 

 

 

-- The above query is located in the UIM application directory: C:\Program Files (x86)\Nimsoft\probes\slm\data_engine\scripts\sqlserver_rehash_checksum.sql

 

2. download and deploy data_engine 9.20HF4 from CA Unified Infrastructure Management Hotfix Index or log a support case to request the fix

 

 

3. Download and deploy the qos_processor hotfix 1.11 from CA Unified Infrastructure Management Hotfix Index or log a support case to request the fix