WA Agent: i5 (AS/400) does stay active or run jobs
search cancel

WA Agent: i5 (AS/400) does stay active or run jobs

book

Article ID: 141079

calendar_today

Updated On:

Products

Workload Automation Agent CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

When CA WA Agent 11.5 is added on manager side (ESP/dSeries/Autosys), the agent may not show up as active.  The WA Agent may not be able to run job due to following key or undecipherable errors.

XX/25/2019 XX:33:21.668 GMT-03:00-0300 2 TCP/IP Controller Plugin.Receiver pool thread <Regular:1>.CybReceiverSession.getMessageOriginator[:393] - Invalid data received
---------------------
00000000 |X2 X0 X1 X9 | |........@.......|
00000010 |X6 XE X0 X5 | |.N....@........@|
......
cybermation.library.afm.CybInvalidAFMException: Invalid AFM
at cybermation.library.afm.CybAFMParser.scan(CybAFMParser.java:329)
at cybermation.library.afm.CybAFMParser.<init>(CybAFMParser.java:151)
...............................
 
XX/25/2019 XX:33:21.668 GMT-03:00-0300 1 TCP/IP Controller Plugin.Transmitter pool thread .CybTargetHandlerChannel.a[:617] - Error sending message to MANAGER:
cybermation.library.communications.CybConversationException: Error sending message: NAK
at cybermation.library.communications.protocol.CybCommunicationProtocolDynamic.sendMessage(CybCommunicationProtocolDynamic.java:994)

 

 

Environment

Release : 11.5

Component : CA WORKLOAD AUTOMATION AGENT

Cause

The 11.5 version may only accept ASCII character code.

Resolution

When setting up the Agent set the Character code to ASCII.

 

E.g. In ESP