Error API-1006 when opening a Roadmap in Clarity PPM
search cancel

Error API-1006 when opening a Roadmap in Clarity PPM

book

Article ID: 141028

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Error message when opening a Roadmap:

API-1006 : The value ''null'' for Attribute 'startDate' is not in expected format or is invalid.

Environment

Clarity PPM 15.7
Clarity PPM 15.6.1

Cause

Somehow the link between Roadmaps and Fiscal Time Periods is broken or NULL. It means the ID supposed to be referencing to a Fiscal Time Period is no longer valid in the Roadmap table. It normally happens if a Fiscal Time Period is removed or deactivated. Even though it is added again, the issue remains.

Resolution

Please, open a ticket at Broadcom Support because it requires a manual intervention. It is not recommended on production environments. Ask for assistance on this issue in order to avoid other unexpected issues as side-effect.