OneClick Webapp does not work when SpectroSERVER and OneClick are using NAT

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Article ID: 140987

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Updated On:

Products

CA Spectrum

Issue/Introduction

Webapp does not work and cannot be launched.  This is due to a NAT environment between the OneClick server and the SpectroSERVER.
From the webswing.log output, you can see the request like:
 
But the response appears to come back as
: -Dwebswing.jmsUrl=nio://127.0.0.1:34455
 
 
 
 
 
 
 

Cause

Webapp does not support NAT environments out of the box.

Environment

Release : 10.4

Component : Spectrum Core / SpectroSERVER

Resolution

1. Go to the Webapp Config webpage

http://<webapp-host>:<webapp-port>/spectrum/admin

2. Login and password is   admin  pwd

3. Click on the Show Config button

4. Go to 3.1 Launcher Configuration and under the Main Arguements add the following before ${customArgs}

-host localhost

So that the entire line should look like:

-contextPort 43000 -compress 9 -host localhost ${customArgs}

** IF SSL (HTTPS) for Webapp is being used then the line will look like **

-contextPort 43000 -compress 9 -host localhost -port <SSL port> -ssl true ${customArgs}

example if port 8443 is the Webapp SSL port it should look like

-contextPort 43000 -compress 9 -host localhost -port 8443 -ssl true ${customArgs}

 5. Click Apply at the top

6. Stop WebTomcat and then start WebTomcat from $SPECROOT/webtomcat/bin


Try to launch Webapp this way


http:<IP>:<webapp-port>/spectrum/oneclickwebapp

 

The IP is the one which they launched the OneClick Admin Webpage


If HTTPS is being used


https:<IP>::9443/spectrum/oneclickwebapp


The IP is the one which they launched the OneClick Admin Webpage

Additional Information

This is scheduled to be fixed out of box in Spectrum 10.4.1.