What if Remote DSS loses contact with MLS?

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Article ID: 140929

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Updated On:

Products

CA eHealth CA Spectrum

Issue/Introduction

We have a large enterprise with many (18) landscapes delineated mostly by location.  We have concerns when a connection from one of the landscapes with the MLS and OneClick is lost, being that we would lose visibility of alarms for that remote location. For example:  We have a landscape monitoring our Brazil network and while the Brazil landscape is still up, and if the communication between that landscape and our core Spectrum servers is lost due to some unforseen network issue, is it still possible to monitor the network activity on the lost DSS?   

Cause

This scenario is in reference to a DSS server in a remote location which may lose contact with the MLS due to network latency or other network issues. This is not pertaining to scenarios where the DSS server may be down. 

Environment

Release : 10.2

Component : Spectrum Core / SpectroSERVER

Resolution

If there is a DSS server (or many) which are physically located in a remote location from the main MLS server location, it is possible to set up a backup MLS server to reside in the remote location with the remote DSS. If contact is lost between the main location and the remote location, the backup MLS will lose contact with the Primary MLS, and therefore will start up as the MLS for that remote location (assuming the backup MLS has been configured for warm or hot ready state). The remote DSS in the same location will then connect to the backup MLS. A backup OneClick server is also recommended to be installed at the remote location, providing users with visibility to the network monitoring of devices modeled on the remote DSS while the connection between the remote location and the main location is repaired. 



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