API Portal - Apps Sync error with OTK Cassandra Database
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API Portal - Apps Sync error with OTK Cassandra Database

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Article ID: 140908

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Updated On:

Products

CA API Developer Portal API SECURITY CA API Gateway

Issue/Introduction

Apps count is always "empty" and never synced with Portal when using a Cassandra Database in OTK

- Scheduled Task "Portal Sync Application" in API Gateway is Enabled, executing the Policy with the same name;

- Policy "Portal Sync Application" includes "Portal Application Sync Fragment" Policy Fragment;

- "Portal API Key Count" is called in the Fragment and the result is stored in a variable called "apikeycount". 

Due to this, the App Sync does not return the right values.

Environment

- CA API Developer Portal 4.3.2

- CA API Gateway 9.4;

- CA OAuth Toolkit 4.3.1;

- OTK With Cassandra Database 

Cause

When using MySQL Databases, a JDBC query is performed and the result count is stored in variable "apiKeyCount.count". When using Cassandra Databases, "Portal API Key Count" is called and the result is stored in a variable called "apikeycount". Since the return variable "postback" is created using "apiKeyCount.count" value, the Cassandra result is never used and the contents of "apiKeyCount.count" is empty.

Resolution

 

In the Portal Application Sync Fragment policy, you will need to add a Context Variable to set apiKeyCount.count.


 

You will need to set the Conext Varaibale after the Portal API Key Count as shown above.

In the Context Variable set a string variable named  apiKeyCount.count to equal apiKeyCount as shown above.  This will allow the policy to complete as expected. 

 

Additional Information

This is being revierwd by our engineering team to be included in a futre release.