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Jasper tomcat fails to start with Error "Connection refused:" when there is an incorrect profile configuration

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Article ID: 140777

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Jasper server tomcat fails to start with the below errors on a windows server environment. 

Using CATALINA_BASE:   "D:\Jaspersoft\Tomcat"

Using CATALINA_HOME:   "D:\Jaspersoft\Tomcat"

Using CATALINA_TMPDIR: "D:\Jaspersoft\Tomcat\temp"

Using JRE_HOME:        "D:\Jaspersoft\Java\jre1.8.0_171"

Using CLASSPATH:       "D:\Jaspersoft\Tomcat\bin\bootstrap.jar;D:\Jaspersoft\Tom

cat\bin\tomcat-juli.jar"

D:\Jaspersoft\Tomcat\bin>shutdown.bat

Using CATALINA_BASE:   "D:\Jaspersoft\Tomcat"

Using CATALINA_HOME:   "D:\Jaspersoft\Tomcat"

Using CATALINA_TMPDIR: "D:\Jaspersoft\Tomcat\temp"

Using JRE_HOME:        "D:\Jaspersoft\Java\jre1.8.0_171"

Using CLASSPATH:       "D:\Jaspersoft\Tomcat\bin\bootstrap.jar;D:\Jaspersoft\Tom

cat\bin\tomcat-juli.jar"

25-Nov-2019 09:41:14.538 SEVERE [main] org.apache.catalina.startup.Catalina.stop

Server Could not contact [localhost:[8005]]. Tomcat may not be running.

25-Nov-2019 09:41:14.538 SEVERE [main] org.apache.catalina.startup.Catalina.stop

Server Catalina.stop:

 java.net.ConnectException: Connection refused: connect

        at java.net.DualStackPlainSocketImpl.connect0(Native Method)

        at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)

        at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)

        at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)

        at java.net.AbstractPlainSocketImpl.connect(Unknown Source)

        at java.net.PlainSocketImpl.connect(Unknown Source)

        at java.net.SocksSocketImpl.connect(Unknown Source)

        at java.net.Socket.connect(Unknown Source)

        at java.net.Socket.connect(Unknown Source)

        at java.net.Socket.<init>(Unknown Source)

        at java.net.Socket.<init>(Unknown Source)

        at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:497)

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

        at java.lang.reflect.Method.invoke(Unknown Source)

        at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:406)

        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:495)

Cause

This is caused by an incorrect user(profile) configuration for Jasper.

Environment

Release : Any

Component : CLARITY JASPERSOFT

Resolution

  1. Stop all running instances of Java (assuming only jasper is installed on the server) using Task Manager.
  2. Log in as the Windows user who installed Jasper as that user's profile contains the License files.
  3. Navigate to the Tomcat bin and start the service.

Additional Information

See also: Jaspersoft / reports known issues with Clarity