CABI Reporting for a specific Spectrum Landscape is not showing data past a certain date
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CABI Reporting for a specific Spectrum Landscape is not showing data past a certain date

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Article ID: 140733

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

CABI reports are not showing data after a certain date. Spectrum Report Manager (SRM) is showing that it has data well past this date but there is no data past it in the reports.
 
 

Environment

DX NetOps Spectrum Release : 20.2 or later
CABI JasperReports 6.4.3 or later

Cause

  • Any Spectrum Server incidents which trigger a large number of events might delay what data is retrievable from SRM.

Resolution

Depending on the size of the event buckets which have yet to be processed some data might not be available to Spectrum Report Manager.

Connect to MySQL Database on OneClick Server where Report Manager is installed:

./mysql --defaults-file=../my-spectrum.cnf -uroot -proot reporting

show tables;

Check for the presence of any alarm buckets which correlate to the problematic landscape:

The alarm bucket naming convention is

SpectroSERVER Landscape_Handle in decimal_unixtime

An Alarm bucket containing 16777216 would have a landscape handle of 0x1000000.


From the above example, at the MySQL command prompt, run:

select count(*) from alarmbucket16777216_1574177644883;

This example query shows this alarm bucket has 45815 events which are still being processed:



So if you then run:

select max(time) from alarmbucket16777216_1574177644883;

You get:

If you run this command a few times throughout the day and notice the (max)time is incrementing than the bucket is still being processed and this data will soon be available for CABI report generation.