UIM - Users and security policy not getting synced from UIM domain to Hub
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UIM - Users and security policy not getting synced from UIM domain to Hub

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Article ID: 140716

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After installation of a new linux hub only the administrator user used while configuring the hub is able to view the status. 

If we log in with any other user, the hub is red mark status (disconnected).

New users created cannot log to the secondary hubs. 

 

Steps tried :

Rename security config and dta file to reset the security settings.

Hub is visible to all with "No Security" notification; if we login to the hub and reset the security settings the issue resurfaces again.

 

 

Environment

Release : UIM 8.x, 9.x, 20.x 

Component : UIM - HUB

Cause

The hub.cfg on the upstream tunnel / proxy hub or the secondary hubs affected by the issue had configuration which was preventing the security information to get propagated downstream 

Resolution

Delete the below keys using hub Raw conifigure from the upstream hubs or on the affected hubs to resolve this issue: 

 

secure_callbacks_from_primary_hub_only = yes

security_config_propagation = no

Additional Information

security.cfg file keeps getting corrupted - need to find way to notify if this file gets changed