UIM - Users and security policy are not getting synced from UIM domain to Hub
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UIM - Users and security policy are not getting synced from UIM domain to Hub

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Article ID: 140716

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

After installation of a new Linux hub, only the administrator user used while configuring the hub is able to view the hub status. 

If we log in with any other user, the hub displays a red mark status (disconnected).

Any new users created cannot log to the secondary hubs. 

 

Steps tried:

Renamed security.cfg and .dta file to reset the security settings.

Hub is visible to all with "No Security" notification; if we login to the hub and reset the security settings the issue resolves but resurfaces again.

Environment

  • Release: UIM 8.x, 9.x, 20.x
  • Component: UIM - HUB

Cause

  • The hub.cfg on the upstream tunnel / proxy hub or the secondary hubs affected by the issue, had a configuration which was preventing the security information to be propagated downstream 

Resolution

Deleted the keys in the hub.cfg using hub Raw configure from the upstream hubs or on the affected hubs to resolve this issue: 

secure_callbacks_from_primary_hub_only = yes

security_config_propagation = no

Additional Information