PKI/CAC Users with Apostrophe's in their name cannot login to PAM

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Article ID: 140708

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Updated On:

Products

CA Privileged Access Manager (PAM) CA Privileged Access Manager - Cloakware Password Authority (PA) PAM SAFENET LUNA HSM CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

When a PKI\CAC User with apostrophe in their name (example):

CN= Test O'Neal +UID=teste01,OU=PAMTEST,O=Government Test,C=US

The end-user will have to be constantly approved everytime the user logs in. 

They get the error message:

PKI-CAM-0977: PKI authentication failed with error.  Client registration in progress

which should go away after the user is approved.  However happens after the initial approval.

Cause

The cause is the apostrophe in their name.  All other users work fine

Environment

Release : 3.3 and 3.3.1

Component : PRIVILEGED ACCESS MANAGEMENT

Resolution

Hotfix 3.3.1.07