Duplicate ServiceNow connector on SOI AdminUI

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Article ID: 140686

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

I have installed ServiceNow connector but it was not showing up on the SOI UI\Administration\Connector Configuration page but it was not showing up, so I installed the connector again. The new ServiceNow connector is showing up along with a second one. Now I have duplicate connector, one of them is working fine and showing online. How do I remove the duplicate one that is showing offline?

Cause

The problem happened because the connector was installed twice and there were two instance of the same connector got inserted in to the ConnectorConfiguration table in SAMStore DB (default SOI DB) in SQL.

Environment

Release : 4.2

Component : Service Operations Insight (SOI) Manager

Resolution

- Stop the catalyst container service on the ServiceNow connector machine.


- Remove the unwanted extra connector from SOI UI\Administration\Connector Configuration page and locate the unwanted connector

  select it and on the left hand side you'll see "Remove Connector" and it should be highlighted, click on it to remove it


- Delete the file from following folder's cache files from ServiceNow connector machine

  CA\Catalyst\CatalystConnector\container\registry-cache


  CA\Catalyst\CatalystConnector\container\nls-store


  CA\Catalyst\CatalystConnector\container\CatalystDatastore


- Start the catalyst container service


Note:

If you don't see the "Remove Connector" button then do the following:


- Backup the SOI DB from SQLManagement Studio


- On SQL Management Studio, right click the SOI DB (default SOI DB is SAMStore) and select New Query then run

  Select * from ConnectorConfiguration


- The above query will provide you with known list of the connector's and one of them will be the unwanted connector. Copy it's connectorID number  and delete it from the DB using the following query (do not delete the catalyst connector and the working Service Now connector)


Delete from ConnectorConfiguration where ConnectorID='ConnectorID you copied'


- Stop the catalyst container from ServiceNow connector


- Delete the file from following folder's cache files from ServiceNow connector machine

  CA\Catalyst\CatalystConnector\container\registry-cache


  CA\Catalyst\CatalystConnector\container\nls-store


  CA\Catalyst\CatalystConnector\container\CatalystDatastore


- Start the catalyst container service