Rally: User story collection tab will not load or will not allow users to add new stories
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Rally: User story collection tab will not load or will not allow users to add new stories

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Article ID: 140669

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Updated On:

Products

Rally On-Premise Rally SaaS

Issue/Introduction

When viewing a Feature (or other lowest level portfolio item type), users are unable to see existing user stories in the User Story Collection tab.  Alternatively, users may be unable to Add New user stories to the collection - given that they have Editor access.

Environment

Release:


Component:

Cause

The issue is caused by a corrupt or invalid saved user preference.  To resolve the issue, each user who is experiencing the issue must clear the saved preference.

Resolution

  1. On your dashboard or a custom page, add the "Custom HTML" app from the App Catalog.
  2. Paste the Preference Deleter code from this URL into the HTML section of the Custom HTML app. and <Save>.
  3. You will be prompted to enter the Preference Name, enter:  data-table-default/-222444/userstories
  4. Make sure there are no beginning or ending spaces in the entry and click Find Preference.
  5. For each preference that is found, please click the Delete button and confirm Delete Preference Permanently.
  6. Once you have deleted all preferences, click the Find Preference button again and ensure that you see a popup box titled Preference Not Found.
  7. Logout immediately (don't navigate to any other page, so as not to save any additional preferences).
  8. Now when you login the User Story Collection has been reset to its default and will load correctly and allow the user to add new user stories.