When we try to access the UMP/ USM screen we are getting an error on a clean install of UIM.

book

Article ID: 140647

calendar_today

Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

When we log into UMP and go to the USM screen we are getting the following error:

We can see the following in the Wasp and portal logs

Wasp log:

Nov 21 17:32:09:873 INFO  [main, com.nimsoft.nimbus.probe.service.wasp.Probe] AJP connector max threads 250
Nov 21 17:32:12:113 INFO  [localhost-startStop-1, org.apache.catalina.core.ContainerBase.[wasp-engine].[localhost].[/]] Initializing Spring root WebApplicationContext
Nov 21 17:32:38:192 ERROR [localhost-startStop-1, org.apache.catalina.core.ContainerBase.[wasp-engine].[localhost].[/]] log() StandardWrapper.Throwable
Nov 21 17:32:38:195 ERROR [localhost-startStop-1, org.apache.catalina.core.ContainerBase.[wasp-engine].[localhost].[/]] java.lang.ExceptionInInitializerError
 at org.portletbridge.portlet.PortletBridgeServlet.init(PortletBridgeServlet.java:103)
 at javax.servlet.GenericServlet.init(GenericServlet.java:158)
 at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1269)
 at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1182)
 at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1072)
 at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:5368)
 at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5660)
 at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:145)
 at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1571)
 at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1561)
 at java.util.concurrent.FutureTask.run(FutureTask.java:266)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
 at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.RuntimeException: org.portletbridge.portlet.GUIDException: error - failure to instantiate GUIDGeneratorjava.net.UnknownHostException: <SOMENAMENOTTHEHOSTORROBOTNAME>:<SOMENAMENOTTHEHOSTORROBOTNAME>:: Name or service not known
 at org.portletbridge.portlet.DefaultIdGenerator.<init>(DefaultIdGenerator.java:45)
 at org.portletbridge.portlet.DefaultIdGenerator.<clinit>(DefaultIdGenerator.java:29)
 ... 14 more
Caused by: org.portletbridge.portlet.GUIDException: error - failure to instantiate GUIDGeneratorjava.net.UnknownHostException: <SOMENAMENOTTHEHOSTORROBOTNAME>: <SOMENAMENOTTHEHOSTORROBOTNAME>: Name or service not known
 at org.portletbridge.portlet.GUIDGenerator.<init>(GUIDGenerator.java:144)
 at org.portletbridge.portlet.DefaultIdGenerator.<init>(DefaultIdGenerator.java:43)
 ... 15 more


From the portal log:

21 Nov 2019 17:32:15,159 INFO  [DialectDetector:136] Found dialect org.hibernate.dialect.MySQLDialect
21 Nov 2019 17:32:15,650 ERROR [Cache:120] Unable to set localhost. This prevents creation of a GUID. Cause was: <SOMENAMENOTTHEHOSTORROBOTNAME>: <SOMENAMENOTTHEHOSTORROBOTNAME>: Name or service not known
java.net.UnknownHostException:<SOMENAMENOTTHEHOSTORROBOTNAME>: <SOMENAMENOTTHEHOSTORROBOTNAME>: Name or service not known
 at java.net.InetAddress.getLocalHost(InetAddress.java:1505)
 at net.sf.ehcache.Cache.<clinit>(Cache.java:200)
 at net.sf.ehcache.config.ConfigurationHelper.createCache(ConfigurationHelper.java:302)

Caused by: java.net.UnknownHostException: <SOMENAMENOTTHEHOSTORROBOTNAME>: Name or service not known

Cause

the hostfile name on the system was set incorrectly and the entry in the /etc/hosts file was not correct.


Environment

UIM/UMP  8.X,9.X

UMP /USM 


OS type and version:( this could be any Linux version)

AME="Amazon Linux AMI"

VERSION="2018.03"

ID="amzn"

ID_LIKE="rhel fedora"

VERSION_ID="2018.03"

PRETTY_NAME="Amazon Linux AMI 2018.03"

ANSI_COLOR="0;33"


Linux auw2nmshub000p 4.14.143-91.122.amzn1.x86_64 #1 SMP Wed Sep 11 00:43:34 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux


Resolution

On the UMP please run the following command and provide the following files.

 

Commands:

ifconfig -a

hostname

 

Files to upload:

/etc/hosts

/etc/resolv.conf

/etc/namedb/named.conf 


Make sure the hostname is set to the proper value usually the same as the robotname.

Make sure the first line entry int he hosts file is the property IPV4 address and the same name as in the hostname


Restart the robot service.


Attachments