Unable to discover or poll already discovered device in Performance Management Data Aggregator
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Unable to discover or poll already discovered device in Performance Management Data Aggregator

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Article ID: 140603

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

A device is able to be discovered as Pingable but not as an SNMP managed device. It may also already be discovered, but now shows as "Management Lost" and is no longer polled for new data. What could cause this?

Environment

All supported Performance Management releases

Cause

We can review Discovery Logging messages via the Data Aggregator (DA) DCDebug page. Access it via the URL:

  • DA_HOST:8581/dcdebug
  • Set the DA_HOST value to the DA host name or IP address.
  • Enter the IP address of the problem device. Select the correct IP Domain it resides in.
  • Select the "Discovery Logging by IP" radio button.
  • Select the View Data button.

If we see all responses from the target device show "REQUEST_TIMED_OUT" it indicates there is a problem with the device responding to the SNMP based Discovery requests sent to it by the Data Collector (DC) that should be managing the device.

Resolution

To validate whether the issue is product or environmental, we can run a simple test with an independent tool like snmpget on the CLI of the DC to see if the response is different. A sample command for SNMPv2c would be:

 

  • snmpget -v 2c -c <communityString> <TargetDevice_IP> system.sysUpTime.0
  • Where <communityString> is the community string for the device.
  • Where <TargetDevice_IP> is the IP used in the attempted discovery.
  • Command can be run from anywhere being a system command
  • Recommend running as root user, or same user as the DC install owner

The command should return a valid response with the devices system up time value.

 

  • If it does not work, if it returns a similar timeout or response failure, it is environmental. If that is the case, there is something wrong on the device, or in the network between DC and device, that is preventing successful SNMP communication.
  • If it does work, if it returns a valid response, it is a product related issue. In this case please open a new support issue for further assistance.

 

 

 

Additional Information

For additional details about the snmpget command usage run "man snmpget".

If the system does not have snmpget installed, it's a common free tool easily installed and very useful for SNMP troubleshooting. The command to install the package of utilities with snmpget is:

  • yum install net-snmp-utils
This will install the following binaries:
  • snmp
  • snmpbulkget
  • snmpdelta
  • snmpinform
  • snmptable
  • snmptrapd
  • snmpbulkwalk
  • snmpdf
  • snmpnetstat
  • snmptest
  • snmpusm
  • snmpconf
  • snmpget
  • snmpset
  • snmptranslate
  • snmpvacm
  • snmpd
  • snmpgetnext
  • snmpstatus
  • snmptrap
  • snmpwalk