Invalid Relational ID for Category of ID When Trying to Delete Knowledge Categories

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Article ID: 140535

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Updated On:

Products

CA Service Management - Service Desk Manager KNOWLEDGE TOOLS

Issue/Introduction

Unable to delete KD categories the following error occurs: Invalid Relational ID for Category of ID : 400051. Possible data corruption.

Cause

The relational_id field of the category tried to be deleted  was set to null, when creating a category the field is automatically populated so this field should not be null. 

Environment

Release : 17.x

Component : SDM KNOWLEDGE MANAGEMENT

Resolution

Take a backup of the database or o_indexes table before proceeding with the steps bellow.

1. Find the id of the category with the issue with the select statement bellow:

select id, caption from o_indexes where caption='category_name'

2. Use the id to edit  the table o_indexes by updating the field relational_id, the format for the relational_id is 1-ID, where ID is the id of the category.

For example:

Category name: Sample Category, ID: 400002 and relational_id: "1-400002"

update o_indexes set relational_id= "1-400002" where id=400002 

3. Log in Service Desk and verify that you are able to delete the category.