Discovering devices with shared IP addresses in Performance Management
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Discovering devices with shared IP addresses in Performance Management

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Article ID: 140527

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Discovering devices that have shared IP addresses in DX NetOps Performance Management

Trying to discover and monitor/manage a pair of Cisco Cat 65xx Virtual Switches. One is an idle standby for the other. They share IP addresses and don't have unique management IP addresses.

Discovering a new device and the Discovery Profile shows it's already an existing discovered device in the History results. The device shown has a different name and IP Address. Reviewing that device in the Data Aggregator (DA) Monitored Devices Inventory entry, the new device's IP is seen as a shared IP from its ipAddress MIB table data.

Can devices be discovered in the Data Aggregator when their IP Address is a shared one appearing in other Device IP Address tables?

Running discovery with logging this message is seen in the logging. It states the new IP with discovery run against it is the duplicate, and that the device item it would have generated will be deleted.

This device is considered as a dup device of <itemID_existingDevice>/<IP_existingDevice). It will be deleted.

Environment

All supported DX NetOps Performance Management releases

Cause

An already discovered device has the new device's IP address in its ipAddress table as a shared IP address.

Without unique management IP addresses to communicate with, Performance Management cannot reliably or accurately discover and manage the two devices.

Resolution

Ensure the devices management IP used for discovery isn't also used as a shared IP in another device's ipAddress table.

Once the IPs are unique between the devices take the following steps to resolve the issue. This example shows 10.10.10.10 as the existing discovered device IP. It shows 10.99.99.99 as the new device IP, the one with its IP listed in 10.10.10.10's ipTable data.

  1. Rediscover the 10.10.10.10 IP device after the shared IP for 10.99.99.99 is removed from its ipAddress MIB table.
  2. Post successful 10.10.10.10 rediscovery, confirm the shared IP 10.99.99.99 is no longer seen in the IP Address entries.
    1. Go to Administration->Monitored Items Management->Monitored Devices.
    2. Search for and select the item for 10.10.10.10 to show its Details tab.
    3. Expand the "IP/MAC Addresses" section.
    4. Confirm the 10.99.99.99 is no longer listed.
  3. Discover the 10.99.99.99 IP device again.

If the 10.99.99.99 isn't removed from the ipTables info on 10.10.10.10, or that change is seen in MIB data but isn't picked up by rediscovery, open a new support case for investigation.

Only after the change is seen in DA inventory details for the devices can we expect the new device discovery to succeed.

Additional Information

There is no way to reliably and accurately discover devices configured in this way in Performance Management. To do so would require an Enhancement Request ER) that is submitted, approved, and implemented to provide this function. Submit a support case referencing this KB article to request an ER submission.