Enterprise Overview not showing data in NFA
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Enterprise Overview not showing data in NFA

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Article ID: 140498

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Updated On:

Products

CA Network Flow Analysis (NetQos / NFA)

Issue/Introduction

The Pump log in the RemoteEngineer output from the \CA\NFA\Reporter\logs directory I can see the Pump service timing out trying to connect to the harvester IP x.x.x.x on port 8080. 

NQS_FIP_00200: Error retrieving http://x.x.x.x:8080/getFiles?do=files&mask=NFMInput/*.*
NetQoS.FilePump.i18nFilePumpException: NQS_FIP_00200: Error retrieving http://x.x.x.x:8080/getFiles?do=files&mask=NFMInput/*.* ---> System.Net.WebException: The operation has timed out

 

Environment

NFA All Versions

Cause

Too many files backed up in the NFMinput directory on one or more Harvesters.

This can happen if the Pump service on the NFA Console is down for a period of time which causes the files in the NFMInput directory to fill up.

Resolution

1. Make sure that port 8080 is open between the NFA Console and the Harvester.

 

2. RDP to the Harvester and check the \CA\NFA\Netflow\datafiles\NFMInput directory and check to see if there are a lot of files in that directory, if there is, delete all of those files and then restart the "CA NFA File Server" Service. 

 

3. RDP to the NFA Console server and restart the Netqos ReporterAnalyzer Pump service.


4. Check the \CA\NFA\Reporter\logs\pump*.log to see if you still see the above errors after 15-30 minutes.

     You can also check the \CA\NFA\Netflow\datafiles\NFMInput directory on the Harvester to make sure the files in that directory get processed quickly.

It will take some time for the Enterprise Overview Data to display again, but if the Errors above or no longer appearing it should start working after some time.